教你安装更新 Laravel 安装器

  • 来源:未录入  2020-09-15 09:41:17 9

下面由Laravel教程栏目给大家介绍安装更新 Laravel 安装器的方法 ,希望对需要的朋友有所帮助!

Laravel

使用 Composer 安装新的 Laravel 安装器很容易,但是如果已经安装了该怎么办?最新的 Laravel 安装器对于您的工作流程至关重要,因此您需要确保获得的是最新版本。如果您有任何问题,我们将为您服务!

如果您还没有听说过,Laravel 团队发布了 Laravel 安装器 软件包的下一个主要版本,其中包括对 Jetstream 的支持。新版本还在幕后使用 composer create-project 命令,而不是从 Laravel 的构建服务器下载归档文件。

随着这项变更,Taylor Otwell 计划 在一两个月内关闭构建服务器,因此您必须尽快升级安装程序。

更新安装器

如果你已经在本地机器中全局引入了 laravel/installer ,你可以使用以下方法将 laravel/installer 更新到最新版本:

  1. 通过 composer require 更新到 ^4.0
  2. 通过 Composer 卸载并重装这个包
  3. 更新全局的 composer.json 文件并且运行 composer update

Composer Require

通过 composer require 全局更新到下一个主要版本最简单的方式是:

composer global require "laravel/installer:^4.0"

只要不存在依赖冲突,现在你应该有了最新的 4.x 的安装器。 我建议每周更新一次(至少在一开始是这样),以获得有关 Laravel 8 的合并更新/bug修复。

如果您要求使用的是 4.x 版本,可以在 Laravel CLI 中验证安装信息:

laravel --version
Laravel Installer 4.0.3

卸载并重新安装

如果通过 composer require 更新时遇到问题,您总是可以通过命令行卸载并重新安装。我们已经提及这种方法,它使用 composer 全局删除旧版本,并重新安装 laravel/installer

composer global remove laravel/installer 
composer global require laravel/installer

更新全局的 composer.json文件

另一种方法是更新全局的 composer.json 文件。对我来说,这个文件的路径是 ~/.composer/composer.json。在写作本文时,最新的 发行版 是 3.2.0;但是,已存在 4.x tags。您需要安装器的 4.x 版本。

调整您的 composer.json 文件以使用 ^ 4.0 版本:

{
    "require": {
        "laravel/installer": "^4.0",
    }
}

返回命令行,运行全局更新:

composer global update

验证更新

如上所述,无论您使用哪种方法来更新安装器,请确保您拥有正确的版本:

laravel --version
Laravel Installer 4.0.3

红利点

我注意到 Laravel 安装器在 Laravel 8 发布当天就收到了一些更新,其中包括诸如 --stack--teams 之类的选项。--stack 选项允许您将堆栈类型配置为 livewireinertia

laravel new myapp --jet --stack=inertia --team

原文地址:https://laravel-news.com/updating-the-laravel-installer

译文地址:https://learnku.com/laravel/t/49603

以上就是教你安装更新 Laravel 安装器的详细内容,更多请关注php中文网其它相关文章!