当前位置:Gxl网 > 运维 > docker支持centos6安装吗

docker支持centos6安装吗

时间:2022-07-27 帮助过:3人阅读 来源: php中文网

docker支持centos6安装;官方文档要求安装docker需要“Linux kernel”至少要在3.8以上,并且docker只能运行在64位系统中,由于“RHEL6”和“CentOS6”的内核版本为2.6,因此必须要先给“CentOS6”系统升级内核之后才能安装。

本教程操作环境:centos6.5系统、docker19.03版、Dell G3电脑。

docker支持centos6安装

官方文档要求Linux kernel至少3.8以上,且docker只能运行在64位的系统中。由于RHEL6和CentOS6的内核版本为2.6,因此必须要先升级内核。

Docker是一个开源的应用容器引擎,可以轻松的为任何应用创建一个轻量级的、可移植的、自给自足的容器。利用Linux的LXC、AUFS、Go语言、cgroup实现了资源的独立,可以很轻松的实现文件、资源、网络等隔离,其最终的目标是实现类似PaaS平台的应用隔离。

下面以CentOS6.5(64位)为例,介绍下docker安装步骤和使用方法:

一、升级内核(带aufs模块)

1、yum安装带aufs模块的3.10内核

cd  /etc/yum .repos.d 
wget http: //www .hop5. in /yum/el6/hop5 .repo
yum  install  kernel-ml-aufs kernel-ml-aufs-devel

2、修改grub的主配置文件/etc/grub.conf,设置default=0,表示第一个title下的内容为默认启动的kernel(一般新安装的内核在第一个位置)。

17.png

3、重启系统,这时候你的内核就成功升级了。

[root@localhost ~] # uname -r
3.10.5-3.el6.x86_64

查看内核是否支持aufs:

[root@localhost ~] # grep aufs /proc/filesystems
nodev    aufs

二、安装docker

1、首先关闭selinux:

setenforce 0
sed  -i  '/^SELINUX=/c\SELINUX=disabled'  /etc/selinux/config

2、在Fedora EPEL源中已经提供了docker-io包,下载安装epel:

rpm -ivh http: //mirrors .sohu.com /fedora-epel/6/x86_64/epel-release-6-8 .noarch.rpm
sed  -i  's/^mirrorlist=https/mirrorlist=http/'  /etc/yum .repos.d /epel .repo

3、yum安装docker-io:

yum -y  install  docker-io

18.png

4、启动docker:

service docker start

19.png

5、查看docker版本:

20.png

查看docker日志:

cat  /var/log/docker

推荐学习:《docker视频教程》

以上就是docker支持centos6安装吗的详细内容,更多请关注gxlsystem.com其它相关文章!

标签 Docker